{"items":[{"id":"NVI-00003478","kind":"vulnerability","title":"Moodle multiple cross-site scripting (XSS) vulnerabilities","revision":2,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected.","NVD lastModified does not establish freshness of every associated CPE record."],"lifecycle":"active","identifiers":["GHSA-f66h-6mj2-rwj2","CVE-2014-3548"],"plain_summary":"OSV carries this publisher advisory for moodle/moodle, moodle/moodle, moodle/moodle, moodle/moodle. This is an aggregated source copy; consult the original publisher and compare update dates.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"The original advisory lists fixed boundaries 2.4.11 for moodle/moodle. Confirm the publisher’s latest guidance.","source_ids":["sr-4020f4a29325e60c6f86a58081ce2b45"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null},{"summary":"The original advisory lists fixed boundaries 2.5.7 for moodle/moodle. Confirm the publisher’s latest guidance.","source_ids":["sr-4020f4a29325e60c6f86a58081ce2b45"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null},{"summary":"The original advisory lists fixed boundaries 2.6.4 for moodle/moodle. Confirm the publisher’s latest guidance.","source_ids":["sr-4020f4a29325e60c6f86a58081ce2b45"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null},{"summary":"The original advisory lists fixed boundaries 2.7.1 for moodle/moodle. Confirm the publisher’s latest guidance.","source_ids":["sr-4020f4a29325e60c6f86a58081ce2b45"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null},{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-bee668b3c0e4c40f1c38b52c6b4bfa66"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-06-17T00:08:27.800Z","value":"4.3 MEDIUM (2.0)","meaning":"nvd@nist.gov severity; no combined Null risk score.","source_id":"sr-bee668b3c0e4c40f1c38b52c6b4bfa66"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-4020f4a29325e60c6f86a58081ce2b45","url":"https://github.com/advisories/GHSA-f66h-6mj2-rwj2","basis":"vendor_advisory","notes":"GitHub-origin advisory, CC-BY-4.0; OSV is an aggregate copy, not independent corroboration.","title":"GHSA-f66h-6mj2-rwj2","publisher":"GitHub Advisory Database via OSV","observed_at":"2026-10-31T21:42:10.709Z"},{"id":"sr-bee668b3c0e4c40f1c38b52c6b4bfa66","url":"https://nvd.nist.gov/vuln/detail/CVE-2014-3548","basis":"official_catalog","notes":"This product uses data from the NVD API but is not endorsed or certified by the NVD.","title":"CVE-2014-3548","publisher":"NIST National Vulnerability Database","observed_at":"2026-10-31T21:56:15.803Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-4020f4a29325e60c6f86a58081ce2b45"],"technology":"moodle/moodle","known_exclusions":[],"conditions_summary":"Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via vectors that trigger an AJAX exception dialog.","public_affected_ranges":["ECOSYSTEM: introduced 0; fixed 2.4.11"]},{"certainty":"source_listed","source_ids":["sr-4020f4a29325e60c6f86a58081ce2b45"],"technology":"moodle/moodle","known_exclusions":[],"conditions_summary":"Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via vectors that trigger an AJAX exception dialog.","public_affected_ranges":["ECOSYSTEM: introduced 2.5.0; fixed 2.5.7"]},{"certainty":"source_listed","source_ids":["sr-4020f4a29325e60c6f86a58081ce2b45"],"technology":"moodle/moodle","known_exclusions":[],"conditions_summary":"Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via vectors that trigger an AJAX exception dialog.","public_affected_ranges":["ECOSYSTEM: introduced 2.6.0; fixed 2.6.4"]},{"certainty":"source_listed","source_ids":["sr-4020f4a29325e60c6f86a58081ce2b45"],"technology":"moodle/moodle","known_exclusions":[],"conditions_summary":"Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via vectors that trigger an AJAX exception dialog.","public_affected_ranges":["ECOSYSTEM: introduced 2.7.0; fixed 2.7.1"]}],"null_published_at":"2026-10-31T22:13:35.668Z","source_updated_at":"2024-12-07T05:39:48.951Z","source_disclosed_at":"2022-05-13T01:12:41.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"Source facts changed; compare the preserved prior revision.","null_first_observed_at":"2026-10-31T21:42:10.709Z"}],"next_cursor":null,"snapshot_revision":"42594"}