{"items":[{"id":"NVI-00004395","kind":"vulnerability","title":"Duplicate Advisory: phpseclib: guardrails needed on isPrime and randomPrime","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"withdrawn","identifiers":["GHSA-hg35-mp25-qf6h"],"plain_summary":"OSV carries this publisher advisory for phpseclib/phpseclib, phpseclib/phpseclib, phpseclib/phpseclib. This is an aggregated source copy; consult the original publisher and compare update dates.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"The original advisory lists fixed boundaries 1.0.23 for phpseclib/phpseclib. Confirm the publisher’s latest guidance.","source_ids":["sr-64b1845e0a55da91fb6c0c4f3825ef07"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null},{"summary":"The original advisory lists fixed boundaries 2.0.47 for phpseclib/phpseclib. Confirm the publisher’s latest guidance.","source_ids":["sr-64b1845e0a55da91fb6c0c4f3825ef07"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null},{"summary":"The original advisory lists fixed boundaries 3.0.36 for phpseclib/phpseclib. Confirm the publisher’s latest guidance.","source_ids":["sr-64b1845e0a55da91fb6c0c4f3825ef07"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-64b1845e0a55da91fb6c0c4f3825ef07","url":"https://github.com/advisories/GHSA-hg35-mp25-qf6h","basis":"vendor_advisory","notes":"GitHub-origin advisory, CC-BY-4.0; OSV is an aggregate copy, not independent corroboration.","title":"GHSA-hg35-mp25-qf6h","publisher":"GitHub Advisory Database via OSV","observed_at":"2026-10-31T21:42:20.429Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-64b1845e0a55da91fb6c0c4f3825ef07"],"technology":"phpseclib/phpseclib","known_exclusions":[],"conditions_summary":"### Duplicate Advisory\nThis advisory has been withdrawn because it is a duplicate of GHSA-2528-jw5q-ww88. This link is maintained to preserve external references.\n\n### Original Description\nAn issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. An attacker can construct a malformed certificate containing an extremely large prime to cause a denial of service (CPU consumption for an isPrime primality check). NOTE: this issue was introduced when attempting to fix CVE-2023-27560.","public_affected_ranges":["ECOSYSTEM: introduced 1.0.0; fixed 1.0.23"]},{"certainty":"source_listed","source_ids":["sr-64b1845e0a55da91fb6c0c4f3825ef07"],"technology":"phpseclib/phpseclib","known_exclusions":[],"conditions_summary":"### Duplicate Advisory\nThis advisory has been withdrawn because it is a duplicate of GHSA-2528-jw5q-ww88. This link is maintained to preserve external references.\n\n### Original Description\nAn issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. An attacker can construct a malformed certificate containing an extremely large prime to cause a denial of service (CPU consumption for an isPrime primality check). NOTE: this issue was introduced when attempting to fix CVE-2023-27560.","public_affected_ranges":["ECOSYSTEM: introduced 2.0.0; fixed 2.0.47"]},{"certainty":"source_listed","source_ids":["sr-64b1845e0a55da91fb6c0c4f3825ef07"],"technology":"phpseclib/phpseclib","known_exclusions":[],"conditions_summary":"### Duplicate Advisory\nThis advisory has been withdrawn because it is a duplicate of GHSA-2528-jw5q-ww88. This link is maintained to preserve external references.\n\n### Original Description\nAn issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. An attacker can construct a malformed certificate containing an extremely large prime to cause a denial of service (CPU consumption for an isPrime primality check). NOTE: this issue was introduced when attempting to fix CVE-2023-27560.","public_affected_ranges":["ECOSYSTEM: introduced 3.0.0; fixed 3.0.36"]}],"null_published_at":"2026-10-31T22:12:52.647Z","source_updated_at":"2026-09-10T03:50:10.583Z","source_disclosed_at":"2024-03-02T00:31:33.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-10-31T21:42:20.429Z"}],"next_cursor":null,"snapshot_revision":"42594"}