{"items":[{"id":"NVI-00004540","kind":"vulnerability","title":"PrestaShop autoupgrade module ZIP archives were vulnerable from CVE-2017-9841","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-wqq8-mqj9-697f"],"plain_summary":"OSV carries this publisher advisory for prestashop/autoupgrade. This is an aggregated source copy; consult the original publisher and compare update dates.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"The original advisory lists fixed boundaries 4.10.1 for prestashop/autoupgrade. Confirm the publisher’s latest guidance.","source_ids":["sr-6a3fd762a0b976aec7aaa43886928611"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-6a3fd762a0b976aec7aaa43886928611","url":"https://github.com/advisories/GHSA-wqq8-mqj9-697f","basis":"vendor_advisory","notes":"GitHub-origin advisory, CC-BY-4.0; OSV is an aggregate copy, not independent corroboration.","title":"GHSA-wqq8-mqj9-697f","publisher":"GitHub Advisory Database via OSV","observed_at":"2026-10-31T21:42:41.390Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-6a3fd762a0b976aec7aaa43886928611"],"technology":"prestashop/autoupgrade","known_exclusions":[],"conditions_summary":"### Impact\n\nWe have identified that some autoupgrade module ZIP archives have been built with phpunit dev dependencies. PHPUnit contains a php script that would allow, on a webserver, an attacker to perform a RCE.\n\nThis vulnerability impacts\n- phpunit before 4.8.28 and 5.x before 5.6.3 as reported in CVE-2017-9841\n- phpunit >= 5.63 before 7.5.19 and 8.5.1 (this is a newly found vulnerability that is currently being submitted as a CVE after disclosure was provided to phpunit maintainers)\n\nYou can read PrestaShop official statement about this vulnerability here.\n\n### Patches\n\nIn the security patch, we look for the unwanted vendor/phpunit folder and remove it if we find it. This allows users to fix the security issue when upgrading.\n\n### Workarounds\nUsers can also simply remove the unwanted vendor/phpunit folder.\n\n### References\nhttps://nvd.nist.gov/vuln/detail/CVE-2017-9841\n\n### For more information\nIf you have any questions or comments about this advisory, email us at security@p","public_affected_ranges":["ECOSYSTEM: introduced 4.0.0; fixed 4.10.1"]}],"null_published_at":"2026-10-31T22:12:57.131Z","source_updated_at":"2024-12-02T05:42:04.260Z","source_disclosed_at":"2020-01-08T03:10:30.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-10-31T21:42:41.390Z"}],"next_cursor":null,"snapshot_revision":"42594"}