{"items":[{"id":"NVI-00004561","kind":"vulnerability","title":"XSS vulnerability with translator","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-5qjq-69w6-fg57","CVE-2021-32671"],"plain_summary":"OSV carries this publisher advisory for flarum/core. This is an aggregated source copy; consult the original publisher and compare update dates.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"The original advisory lists fixed boundaries 1.0.2 for flarum/core. Confirm the publisher’s latest guidance.","source_ids":["sr-6ad85337ac1cc6c489db3a73bfa98b91"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-6ad85337ac1cc6c489db3a73bfa98b91","url":"https://github.com/advisories/GHSA-5qjq-69w6-fg57","basis":"vendor_advisory","notes":"GitHub-origin advisory, CC-BY-4.0; OSV is an aggregate copy, not independent corroboration.","title":"GHSA-5qjq-69w6-fg57","publisher":"GitHub Advisory Database via OSV","observed_at":"2026-10-31T21:41:59.926Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-6ad85337ac1cc6c489db3a73bfa98b91"],"technology":"flarum/core","known_exclusions":[],"conditions_summary":"Flarum's translation system allowed for string inputs to be converted into HTML DOM nodes when rendered. This change was made after v0.1.0-beta.16 (our last beta before v1.0.0) and was not noticed or documented.\n\nThis allowed for any user to type malicious HTML markup within certain user input fields and have this execute on client browsers. The example which led to the discovery of this vulnerability was in the forum search box. Entering faux-malicious HTML markup, such as alert('test') resulted in an alert box appearing on the forum. This attack could also be modified to perform AJAX requests on behalf of a user, possibly deleting discussions, modifying their settings or profile, or even modifying settings on the Admin panel if the attack was targetted towards a privileged user.\n\n### Impact\n\nAll Flarum communities that run flarum v1.0.0 or v1.0.1 are impacted.\n\n### Patches\n\nThe vulnerability has been fixed and published as flarum/core v1.0.2. All communities running Flarum v1.0 have to upgrade as soon as possible to v1.0.2 using:\n\n```\ncomposer update --prefer-dist --no-dev -a -W\n```\n\nYou can then confirm you run the latest version using:\n\n```\ncomposer show flarum","public_affected_ranges":["ECOSYSTEM: introduced 1.0.0; fixed 1.0.2"]}],"null_published_at":"2026-10-31T22:12:57.131Z","source_updated_at":"2026-07-08T06:27:58.764Z","source_disclosed_at":"2021-06-07T21:48:17.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-10-31T21:41:59.926Z"}],"next_cursor":null,"snapshot_revision":"42594"}