{"items":[{"id":"NVI-00004640","kind":"vulnerability","title":"Moodle XSS Vulnerability","revision":3,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected.","NVD lastModified does not establish freshness of every associated CPE record."],"lifecycle":"active","identifiers":["GHSA-7ghm-fp7p-qvjq","CVE-2016-9188"],"plain_summary":"OSV carries this publisher advisory for moodle/moodle. This is an aggregated source copy; consult the original publisher and compare update dates.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-1678f05ccd70fc9d5128203edd1b95e8"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-06-17T00:55:39.013Z","value":"4.3 MEDIUM (2.0)","meaning":"nvd@nist.gov severity; no combined Null risk score.","source_id":"sr-fb5d805c0f41416c45fb516abfb02caf"},{"kind":"CVSS","as_of":"2026-06-17T00:55:39.013Z","value":"6.1 MEDIUM (3.0)","meaning":"nvd@nist.gov severity; no combined Null risk score.","source_id":"sr-fb5d805c0f41416c45fb516abfb02caf"},{"kind":"EPSS","as_of":"2026-10-31T12:00:27.000Z","value":"1.536%","meaning":"FIRST EPSS model v2026.06.15; exploitation probability over 30 days, percentile 0.74859. Missing scores are unknown.","source_id":"sr-1678f05ccd70fc9d5128203edd1b95e8"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-6df99302fec6049ced76e7e7b78209c9","url":"https://github.com/advisories/GHSA-7ghm-fp7p-qvjq","basis":"vendor_advisory","notes":"GitHub-origin advisory, CC-BY-4.0; OSV is an aggregate copy, not independent corroboration.","title":"GHSA-7ghm-fp7p-qvjq","publisher":"GitHub Advisory Database via OSV","observed_at":"2026-10-31T21:41:59.949Z"},{"id":"sr-fb5d805c0f41416c45fb516abfb02caf","url":"https://nvd.nist.gov/vuln/detail/CVE-2016-9188","basis":"official_catalog","notes":"This product uses data from the NVD API but is not endorsed or certified by the NVD.","title":"CVE-2016-9188","publisher":"NIST National Vulnerability Database","observed_at":"2026-10-31T21:56:40.309Z"},{"id":"sr-1678f05ccd70fc9d5128203edd1b95e8","url":"https://www.first.org/epss/data.html","basis":"official_catalog","notes":"FIRST EPSS; probability of exploitation in the next 30 days, not local compromise. Dataset date/model retained; FIRST services terms apply.","title":"CVE-2016-9188","publisher":"FIRST EPSS","observed_at":"2026-10-31T22:06:03.704Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-6df99302fec6049ced76e7e7b78209c9"],"technology":"moodle/moodle","known_exclusions":[],"conditions_summary":"Cross-site scripting (XSS) vulnerabilities in Moodle CMS on or before 3.1.2 allow remote attackers to inject arbitrary web script or HTML via the s_additionalhtmlhead, s_additionalhtmltopofbody, and s_additionalhtmlfooter parameters.","public_affected_ranges":["ECOSYSTEM: introduced 2.0.1; last_affected 3.2.1"]}],"null_published_at":"2026-10-31T22:27:06.723Z","source_updated_at":"2024-02-16T08:09:03.804Z","source_disclosed_at":"2022-05-17T03:38:33.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"Dated EPSS estimate updated; this is not a new disclosure or proof of exploitation.","null_first_observed_at":"2026-10-31T21:41:59.949Z"},{"id":"NVI-00004640","kind":"vulnerability","title":"Moodle XSS Vulnerability","revision":2,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected.","NVD lastModified does not establish freshness of every associated CPE record."],"lifecycle":"active","identifiers":["GHSA-7ghm-fp7p-qvjq","CVE-2016-9188"],"plain_summary":"OSV carries this publisher advisory for moodle/moodle. This is an aggregated source copy; consult the original publisher and compare update dates.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-fb5d805c0f41416c45fb516abfb02caf"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-06-17T00:55:39.013Z","value":"4.3 MEDIUM (2.0)","meaning":"nvd@nist.gov severity; no combined Null risk score.","source_id":"sr-fb5d805c0f41416c45fb516abfb02caf"},{"kind":"CVSS","as_of":"2026-06-17T00:55:39.013Z","value":"6.1 MEDIUM (3.0)","meaning":"nvd@nist.gov severity; no combined Null risk score.","source_id":"sr-fb5d805c0f41416c45fb516abfb02caf"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-6df99302fec6049ced76e7e7b78209c9","url":"https://github.com/advisories/GHSA-7ghm-fp7p-qvjq","basis":"vendor_advisory","notes":"GitHub-origin advisory, CC-BY-4.0; OSV is an aggregate copy, not independent corroboration.","title":"GHSA-7ghm-fp7p-qvjq","publisher":"GitHub Advisory Database via OSV","observed_at":"2026-10-31T21:41:59.949Z"},{"id":"sr-fb5d805c0f41416c45fb516abfb02caf","url":"https://nvd.nist.gov/vuln/detail/CVE-2016-9188","basis":"official_catalog","notes":"This product uses data from the NVD API but is not endorsed or certified by the NVD.","title":"CVE-2016-9188","publisher":"NIST National Vulnerability Database","observed_at":"2026-10-31T21:56:40.309Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-6df99302fec6049ced76e7e7b78209c9"],"technology":"moodle/moodle","known_exclusions":[],"conditions_summary":"Cross-site scripting (XSS) vulnerabilities in Moodle CMS on or before 3.1.2 allow remote attackers to inject arbitrary web script or HTML via the s_additionalhtmlhead, s_additionalhtmltopofbody, and s_additionalhtmlfooter parameters.","public_affected_ranges":["ECOSYSTEM: introduced 2.0.1; last_affected 3.2.1"]}],"null_published_at":"2026-10-31T22:13:39.923Z","source_updated_at":"2024-02-16T08:09:03.804Z","source_disclosed_at":"2022-05-17T03:38:33.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"Source facts changed; compare the preserved prior revision.","null_first_observed_at":"2026-10-31T21:41:59.949Z"}],"next_cursor":null,"snapshot_revision":"42594"}