{"items":[{"id":"NVI-00004875","kind":"vulnerability","title":"laravel-auth0 SDK Does Not Properly Handle File Types in Bulk User Import","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-hjfh-5jmm-xr24"],"plain_summary":"OSV carries this publisher advisory for auth0/login. This is an aggregated source copy; consult the original publisher and compare update dates.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"The original advisory lists fixed boundaries 7.19.0 for auth0/login. Confirm the publisher’s latest guidance.","source_ids":["sr-772aec14ad145bfa0557cccfcbc9c106"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-772aec14ad145bfa0557cccfcbc9c106","url":"https://github.com/advisories/GHSA-hjfh-5jmm-xr24","basis":"vendor_advisory","notes":"GitHub-origin advisory, CC-BY-4.0; OSV is an aggregate copy, not independent corroboration.","title":"GHSA-hjfh-5jmm-xr24","publisher":"GitHub Advisory Database via OSV","observed_at":"2026-10-31T21:42:20.430Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-772aec14ad145bfa0557cccfcbc9c106"],"technology":"auth0/login","known_exclusions":[],"conditions_summary":"### Overview\nIn applications built with the Auth0-PHP SDK, the Bulk User Import endpoint does not validate the file path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs.\n\n### Am I affected?\nYou are affected by this vulnerability if you meet the following preconditions:\n1. Applications using the Auth0 laravel-auth0 SDK with version between 4.0.0 and 7.18.0,\n2. Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 3.3.0 and 8.16.0.\n\n### Fix\nUpgrade Auth0 laravel-auth0 SDK to version 7.19.0 or greater.\n\n### Acknowledgement\nOkta would like to thank Mohamed Amine Saidani (pwni) for discovering this vulnerability.","public_affected_ranges":["ECOSYSTEM: introduced 4.0.0; fixed 7.19.0"]}],"null_published_at":"2026-10-31T22:12:57.146Z","source_updated_at":"2026-02-04T04:40:03.690Z","source_disclosed_at":"2025-10-01T21:21:06.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-10-31T21:42:20.430Z"}],"next_cursor":null,"snapshot_revision":"42594"}