{"items":[{"id":"NVI-00007526","kind":"vulnerability","title":"contao/core Insufficient input validation allows for code injection and remote execution","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-wxxw-5gq6-j2g5"],"plain_summary":"OSV carries this publisher advisory for contao/core, contao/core. This is an aggregated source copy; consult the original publisher and compare update dates.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"The original advisory lists fixed boundaries 2.11.17 for contao/core. Confirm the publisher’s latest guidance.","source_ids":["sr-ded844f03702a79b0d70c7253c9a402c"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null},{"summary":"The original advisory lists fixed boundaries 3.2.9 for contao/core. Confirm the publisher’s latest guidance.","source_ids":["sr-ded844f03702a79b0d70c7253c9a402c"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-ded844f03702a79b0d70c7253c9a402c","url":"https://github.com/advisories/GHSA-wxxw-5gq6-j2g5","basis":"vendor_advisory","notes":"GitHub-origin advisory, CC-BY-4.0; OSV is an aggregate copy, not independent corroboration.","title":"GHSA-wxxw-5gq6-j2g5","publisher":"GitHub Advisory Database via OSV","observed_at":"2026-10-31T21:42:51.437Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-ded844f03702a79b0d70c7253c9a402c"],"technology":"contao/core","known_exclusions":[],"conditions_summary":"contao/core versions 2.x prior to 2.11.17 and 3.x prior to 3.2.9 are vulnerable to arbitrary code execution on the server due to insufficient input validation. In fact, attackers can remove or change pathconfig.php by entering a URL, meaning that the entire Contao installation will no longer be accessible or malicious code can be executed.","public_affected_ranges":["ECOSYSTEM: introduced 2.0.0; fixed 2.11.17"]},{"certainty":"source_listed","source_ids":["sr-ded844f03702a79b0d70c7253c9a402c"],"technology":"contao/core","known_exclusions":[],"conditions_summary":"contao/core versions 2.x prior to 2.11.17 and 3.x prior to 3.2.9 are vulnerable to arbitrary code execution on the server due to insufficient input validation. In fact, attackers can remove or change pathconfig.php by entering a URL, meaning that the entire Contao installation will no longer be accessible or malicious code can be executed.","public_affected_ranges":["ECOSYSTEM: introduced 3.0.0; fixed 3.2.9"]}],"null_published_at":"2026-10-31T22:13:18.623Z","source_updated_at":"2024-11-29T05:35:05.118Z","source_disclosed_at":"2024-05-15T18:31:02.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-10-31T21:42:51.437Z"}],"next_cursor":null,"snapshot_revision":"42594"}