{"items":[{"id":"NVI-00007680","kind":"vulnerability","title":"Persistent Cross-site Scripting vulnerability in PrivateBin","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-cqcc-mm6x-vmvw","CVE-2022-24833"],"plain_summary":"OSV carries this publisher advisory for privatebin/privatebin. This is an aggregated source copy; consult the original publisher and compare update dates.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"The original advisory lists fixed boundaries 1.4.0 for privatebin/privatebin. Confirm the publisher’s latest guidance.","source_ids":["sr-e441901ea5cf394477cb396a73c5843a"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-e441901ea5cf394477cb396a73c5843a","url":"https://github.com/advisories/GHSA-cqcc-mm6x-vmvw","basis":"vendor_advisory","notes":"GitHub-origin advisory, CC-BY-4.0; OSV is an aggregate copy, not independent corroboration.","title":"GHSA-cqcc-mm6x-vmvw","publisher":"GitHub Advisory Database via OSV","observed_at":"2026-10-31T21:42:10.702Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-e441901ea5cf394477cb396a73c5843a"],"technology":"privatebin/privatebin","known_exclusions":[],"conditions_summary":"In PrivateBin < v1.4.0 a cross-site scripting (XSS) vulnerability was found. The vulnerability is present since attachments with image preview got introduced in v0.21 of the project, which was at the time still called ZeroBin. The issue is caused by the fact that SVGs can contain JavaScript. This can allow an attacker to execute code, if the user opens a paste with a specifically crafted SVG attachment, and interacts with the preview image and the instance isn't protected by an appropriate content security policy.\n\nAs a consequence, we have mitigated the vulnerability in the preview and urge server administrators to either **upgrade** to a version with the fix or to ensure the content security policy of their instance is set correctly, ideally both. Additionally, we expanded our directory listing tool with a checking mechanism and **highly suggest server administrators to check their instance there** and, should there be a warning regarding the content security policy **adjust the CSP to our suggested one**, as it is shown in the configuration preset.\n\n## Proof of concept\n\nThe vulnerability can be triggered as following:\n\n1. Create the fol","public_affected_ranges":["ECOSYSTEM: introduced 0.21; fixed 1.4.0"]}],"null_published_at":"2026-10-31T22:13:18.630Z","source_updated_at":"2023-11-08T04:08:38.122Z","source_disclosed_at":"2022-04-12T20:45:22.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-10-31T21:42:10.702Z"}],"next_cursor":null,"snapshot_revision":"42594"}