{"items":[{"id":"NVI-00007966","kind":"vulnerability","title":"Doctrine SQL injection vulnerability","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-6q9v-4hq6-5m67"],"plain_summary":"OSV carries this publisher advisory for doctrine/orm, doctrine/orm. This is an aggregated source copy; consult the original publisher and compare update dates.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"The original advisory lists fixed boundaries 2.0.3 for doctrine/orm. Confirm the publisher’s latest guidance.","source_ids":["sr-f034a1115ac1aa65fd3c4749678ac363"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null},{"summary":"The original advisory lists fixed boundaries 1.2.4 for doctrine/orm. Confirm the publisher’s latest guidance.","source_ids":["sr-f034a1115ac1aa65fd3c4749678ac363"],"action_type":"vendor_patch","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-f034a1115ac1aa65fd3c4749678ac363","url":"https://github.com/advisories/GHSA-6q9v-4hq6-5m67","basis":"vendor_advisory","notes":"GitHub-origin advisory, CC-BY-4.0; OSV is an aggregate copy, not independent corroboration.","title":"GHSA-6q9v-4hq6-5m67","publisher":"GitHub Advisory Database via OSV","observed_at":"2026-10-31T21:41:59.939Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-f034a1115ac1aa65fd3c4749678ac363"],"technology":"doctrine/orm","known_exclusions":[],"conditions_summary":"Doctrine is prone to SQL injection vulnerability. Users of Doctrine 1.2 and 2 should update to the newly released versions of both libraries immediately. Both versions only include the security fix and no other changes to their previous versions 1.2.3 and 2.0.2.\n\nAffected versions are:\n- 1.2.3 and earlier for PostgreSQL and DB2 Dialects\n- 2.0.2 and earlier\n\nThe security issue was found to affect the `Doctrine\\DBAL\\Platforms\\AbstractPlatform::modifyLimitQuery()` function which does not cast input values for limit and offset to integer and allows malicious SQL to be executed if these parameters are passed into Doctrine 2 directly from request variables without previous cast to integer. Functionality building on top using limit queries in the ORM such as `Doctrine\\ORM\\Query::setFirstResult()` and `Doctrine\\ORM\\Query::setMaxResults()` are also affected by this security issue.\n\nThe fix for this security issue breaks backwards compatibility for developers that extend the `Doctrine\\DBAL\\Platforms\\AbstractPlatform::modifyLimitQuery()` method, because it is now marked as final. Please overwrite the `Doctrine\\DBAL\\Platforms\\AbstractPlatform::doModifyLimitQuery()` method instead.","public_affected_ranges":["ECOSYSTEM: introduced 2.0.0; fixed 2.0.3"]},{"certainty":"source_listed","source_ids":["sr-f034a1115ac1aa65fd3c4749678ac363"],"technology":"doctrine/orm","known_exclusions":[],"conditions_summary":"Doctrine is prone to SQL injection vulnerability. Users of Doctrine 1.2 and 2 should update to the newly released versions of both libraries immediately. Both versions only include the security fix and no other changes to their previous versions 1.2.3 and 2.0.2.\n\nAffected versions are:\n- 1.2.3 and earlier for PostgreSQL and DB2 Dialects\n- 2.0.2 and earlier\n\nThe security issue was found to affect the `Doctrine\\DBAL\\Platforms\\AbstractPlatform::modifyLimitQuery()` function which does not cast input values for limit and offset to integer and allows malicious SQL to be executed if these parameters are passed into Doctrine 2 directly from request variables without previous cast to integer. Functionality building on top using limit queries in the ORM such as `Doctrine\\ORM\\Query::setFirstResult()` and `Doctrine\\ORM\\Query::setMaxResults()` are also affected by this security issue.\n\nThe fix for this security issue breaks backwards compatibility for developers that extend the `Doctrine\\DBAL\\Platforms\\AbstractPlatform::modifyLimitQuery()` method, because it is now marked as final. Please overwrite the `Doctrine\\DBAL\\Platforms\\AbstractPlatform::doModifyLimitQuery()` method instead.","public_affected_ranges":["ECOSYSTEM: introduced 1.0.0; fixed 1.2.4"]}],"null_published_at":"2026-10-31T22:13:18.642Z","source_updated_at":"2024-05-15T20:14:15.000Z","source_disclosed_at":"2024-05-15T20:14:15.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-10-31T21:41:59.939Z"}],"next_cursor":null,"snapshot_revision":"42594"}