{"items":[{"id":"NVI-00008852","kind":"vulnerability","title":"OpenAM: Pre-auth RCE via Java Deserialization in WebAuthn Authenticator Storage","revision":2,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected.","NVD lastModified does not establish freshness of every associated CPE record."],"lifecycle":"active","identifiers":["GHSA-6c99-87fr-6q7r","CVE-2026-45051"],"plain_summary":"GitHub lists this reviewed advisory for org.openidentityplatform.openam:openam-auth-webauthn. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-12881383c358bbf25fbdb80d91c7627d"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-09-23T18:21:42.327Z","value":"9.2 CRITICAL (4.0)","meaning":"security-advisories@github.com severity; no combined Null risk score.","source_id":"sr-12881383c358bbf25fbdb80d91c7627d"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-04a2b84e4e402a53440b041a4f7b6716","url":"https://github.com/advisories/GHSA-6c99-87fr-6q7r","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-6c99-87fr-6q7r","publisher":"GitHub Advisory Database","observed_at":"2026-10-31T21:56:36.327Z"},{"id":"sr-12881383c358bbf25fbdb80d91c7627d","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-45051","basis":"official_catalog","notes":"This product uses data from the NVD API but is not endorsed or certified by the NVD.","title":"CVE-2026-45051","publisher":"NIST National Vulnerability Database","observed_at":"2026-11-03T22:35:20.969Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-04a2b84e4e402a53440b041a4f7b6716"],"technology":"org.openidentityplatform.openam:openam-auth-webauthn","known_exclusions":[],"conditions_summary":"## Summary\n\n**Description**\n\nA deserialization of untrusted data vulnerability (CWE-502) exists in OpenAM's WebAuthn authentication module. Under certain conditions, this may allow an attacker to achieve arbitrary code execution in the context of the application server. This affects OpenAM Community Edition through version 16.0.6 and was patched in version 16.1.1.\n\nThis is not the default configuration. Exploitation requires that an attacker has previously been able to write attacker-controlled data to a storage attribute read by the WebAuthn module, and that the WebAuthn authentication flow is reachable.\n\n## Impact\nWebAuthn is a modern shipped module, but the vulnerable configuration requires either the default storage attribute to become attacker-writable, or the WebAuthn userAttribute to be set to an attacker-writable string attribute. That is not the default, but it is feasible in deployments because the product exposes the storage attribute as a free-form admin setting and does not warn or enforce that it must be server-managed and non-user-writable. This may exist through delegated administration, provisioning, write access to the backing LDAP/directory user record, legacy RE","public_affected_ranges":["<= 16.0.6"]}],"null_published_at":"2026-11-04T10:04:35.909Z","source_updated_at":"2026-10-28T15:25:32.000Z","source_disclosed_at":"2026-06-24T17:25:28.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"Source facts changed; compare the preserved prior revision.","null_first_observed_at":"2026-10-31T21:56:36.327Z"},{"id":"NVI-00008852","kind":"vulnerability","title":"OpenAM: Pre-auth RCE via Java Deserialization in WebAuthn Authenticator Storage","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-6c99-87fr-6q7r","CVE-2026-45051"],"plain_summary":"GitHub lists this reviewed advisory for org.openidentityplatform.openam:openam-auth-webauthn. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-04a2b84e4e402a53440b041a4f7b6716"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-04a2b84e4e402a53440b041a4f7b6716","url":"https://github.com/advisories/GHSA-6c99-87fr-6q7r","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-6c99-87fr-6q7r","publisher":"GitHub Advisory Database","observed_at":"2026-10-31T21:56:36.327Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-04a2b84e4e402a53440b041a4f7b6716"],"technology":"org.openidentityplatform.openam:openam-auth-webauthn","known_exclusions":[],"conditions_summary":"## Summary\n\n**Description**\n\nA deserialization of untrusted data vulnerability (CWE-502) exists in OpenAM's WebAuthn authentication module. Under certain conditions, this may allow an attacker to achieve arbitrary code execution in the context of the application server. This affects OpenAM Community Edition through version 16.0.6 and was patched in version 16.1.1.\n\nThis is not the default configuration. Exploitation requires that an attacker has previously been able to write attacker-controlled data to a storage attribute read by the WebAuthn module, and that the WebAuthn authentication flow is reachable.\n\n## Impact\nWebAuthn is a modern shipped module, but the vulnerable configuration requires either the default storage attribute to become attacker-writable, or the WebAuthn userAttribute to be set to an attacker-writable string attribute. That is not the default, but it is feasible in deployments because the product exposes the storage attribute as a free-form admin setting and does not warn or enforce that it must be server-managed and non-user-writable. This may exist through delegated administration, provisioning, write access to the backing LDAP/directory user record, legacy RE","public_affected_ranges":["<= 16.0.6"]}],"null_published_at":"2026-10-31T22:13:27.119Z","source_updated_at":"2026-10-28T15:25:32.000Z","source_disclosed_at":"2026-06-24T17:25:28.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-10-31T21:56:36.327Z"}],"next_cursor":null,"snapshot_revision":"42594"}