{"items":[{"id":"NVI-00011908","kind":"vulnerability","title":"Ghost: Stored XSS via Embed Card Previews","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-69qc-f5m6-889c","CVE-2026-105643"],"plain_summary":"GitHub lists this reviewed advisory for ghost. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-59e4890b695a98c54012d51e3b2c21fd"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-10-07T20:43:07.000Z","value":"7.3 high","meaning":"GitHub source severity; exploitability and local consequence require separate evidence.","source_id":"sr-59e4890b695a98c54012d51e3b2c21fd"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-59e4890b695a98c54012d51e3b2c21fd","url":"https://github.com/advisories/GHSA-69qc-f5m6-889c","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-69qc-f5m6-889c","publisher":"GitHub Advisory Database","observed_at":"2026-11-01T00:58:38.867Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-59e4890b695a98c54012d51e3b2c21fd"],"technology":"ghost","known_exclusions":[],"conditions_summary":"### Impact\n\nEmbed cards in the Ghost editor could be used to bypass the fix for GHSA-8vhf-xxpj-4qrg. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, possibly resulting in compromise of that user's admin session.\n\nSelf-hosted sites should leave the new `security.embedPreviewUrl` config option at its default. \n\n### Vulnerable versions\n\nThis vulnerability is present in Ghost from v6.34.0 up to v6.65.0.\n\n### Patches\n\nv6.67.0 contains a fix for this issue.\n\n### How to update\n\nFor self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. \n\nIf your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here. \n\n### References\n\nGhost thanks DONG2209 (Dong Nguyen) and Pedro Pinho for disclosing this vulnerability responsibly.\n\n### For more information\n\nIf you have any questions or comments about this advisory, email us at [security@ghost.org](mailto:","public_affected_ranges":[">= 6.34.0, < 6.67.0"]}],"null_published_at":"2026-11-01T01:03:56.614Z","source_updated_at":"2026-10-07T20:43:07.000Z","source_disclosed_at":"2026-10-07T20:43:05.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-01T00:58:38.867Z"}],"next_cursor":null,"snapshot_revision":"39771"}