{"items":[{"id":"NVI-00012921","kind":"vulnerability","title":"Duplicate Advisory: Flowise Execute Flow function has an SSRF vulnerability","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"withdrawn","identifiers":["GHSA-w4hm-rrxg-pxcf"],"plain_summary":"GitHub lists this reviewed advisory for flowise. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-0b4a2f723e0a9c3ef5e1fd6648bb107a"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-09-23T21:24:53.000Z","value":"7.1 medium","meaning":"GitHub source severity; exploitability and local consequence require separate evidence.","source_id":"sr-0b4a2f723e0a9c3ef5e1fd6648bb107a"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-0b4a2f723e0a9c3ef5e1fd6648bb107a","url":"https://github.com/advisories/GHSA-w4hm-rrxg-pxcf","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-w4hm-rrxg-pxcf","publisher":"GitHub Advisory Database","observed_at":"2026-11-01T07:25:10.521Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-0b4a2f723e0a9c3ef5e1fd6648bb107a"],"technology":"flowise","known_exclusions":[],"conditions_summary":"### Duplicate Advisory\nThis advisory has been withdrawn because it is a duplicate of GHSA-9hrv-gvrv-6gf2. This link is maintained to preserve external references.\n\n### Original Description\nFlowise before 3.1.0 contains a server-side request forgery vulnerability in the Execute Flow node that allows attackers to bypass security validation by providing intranet addresses through the base URL field. Attackers can initiate HTTP requests to internal network addresses, access cloud metadata, and enumerate internal services by exploiting the missing secureFetch verification in httpSecurity.ts.","public_affected_ranges":["< 3.1.0"]}],"null_published_at":"2026-11-01T07:29:12.902Z","source_updated_at":"2026-09-23T21:24:53.000Z","source_disclosed_at":"2026-06-23T15:32:36.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-01T07:25:10.521Z"}],"next_cursor":null,"snapshot_revision":"39771"}