{"items":[{"id":"NVI-00013775","kind":"vulnerability","title":"Flowise OverrideConfig security vulnerability","revision":2,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-5cph-wvm9-45gj","CVE-2024-58351"],"plain_summary":"GitHub lists this reviewed advisory for flowise. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-1098d218072d0cccb69eb876ef6c5c17"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"EPSS","as_of":"2026-11-04T12:03:12.000Z","value":"0.662%","meaning":"FIRST EPSS model v2026.06.15; exploitation probability over 30 days, percentile 0.51764. Missing scores are unknown.","source_id":"sr-1098d218072d0cccb69eb876ef6c5c17"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-00ad3186e578e05af4add6a7e39fd67e","url":"https://github.com/advisories/GHSA-5cph-wvm9-45gj","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-5cph-wvm9-45gj","publisher":"GitHub Advisory Database","observed_at":"2026-11-01T22:54:05.264Z"},{"id":"sr-1098d218072d0cccb69eb876ef6c5c17","url":"https://www.first.org/epss/data.html","basis":"official_catalog","notes":"FIRST EPSS; probability of exploitation in the next 30 days, not local compromise. Dataset date/model retained; FIRST services terms apply.","title":"CVE-2024-58351","publisher":"FIRST EPSS","observed_at":"2026-11-04T17:58:50.299Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-00ad3186e578e05af4add6a7e39fd67e"],"technology":"flowise","known_exclusions":[],"conditions_summary":"### Impact\nFlowise allows developers to inject configuration into the Chainflow during execution through the `overrideConfig` option. This is supported in both the frontend web integration and the backend Prediction API. \n\nThis has a range of fundamental issues that are a **major** security vulnerability. \nWhile this feature is intentional, it should have strong protections added and be disabled by default. \n\nThese issues include: \n1. Remote code execution. While inside a sandbox this allows for\n  1. Sandbox escape \n  2. DoS by crashing the server\n  3. SSRF\n2. Prompt Injection, both System and User\n  1. Full control over LLM prompts\n  2. Server variable and data exfiltration\nAnd many many more such as altering the flow of a conversation, prompt exfiltration via LLM proxying etc.\n\nThese issues are self-targeted and do not persist to other users but do leave the server and business exposed. \nAll issues are shown with the API but also work with the web embed.\n\n### Workarounds\n- `overrideConfig` should be disabled by default\n- `overrideConfig` should have an explicit allow list of variables that are allowed to be modified. This way the user opts-in to where modifications can be made. \n","public_affected_ranges":["< 2.1.4"]}],"null_published_at":"2026-11-07T14:02:01.398Z","source_updated_at":"2026-09-14T17:15:31.000Z","source_disclosed_at":"2024-11-21T22:21:03.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"Dated EPSS estimate updated; this is not a new disclosure or proof of exploitation.","null_first_observed_at":"2026-11-01T22:54:05.264Z"},{"id":"NVI-00013775","kind":"vulnerability","title":"Flowise OverrideConfig security vulnerability","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-5cph-wvm9-45gj","CVE-2024-58351"],"plain_summary":"GitHub lists this reviewed advisory for flowise. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-00ad3186e578e05af4add6a7e39fd67e"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-00ad3186e578e05af4add6a7e39fd67e","url":"https://github.com/advisories/GHSA-5cph-wvm9-45gj","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-5cph-wvm9-45gj","publisher":"GitHub Advisory Database","observed_at":"2026-11-01T22:54:05.264Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-00ad3186e578e05af4add6a7e39fd67e"],"technology":"flowise","known_exclusions":[],"conditions_summary":"### Impact\nFlowise allows developers to inject configuration into the Chainflow during execution through the `overrideConfig` option. This is supported in both the frontend web integration and the backend Prediction API. \n\nThis has a range of fundamental issues that are a **major** security vulnerability. \nWhile this feature is intentional, it should have strong protections added and be disabled by default. \n\nThese issues include: \n1. Remote code execution. While inside a sandbox this allows for\n  1. Sandbox escape \n  2. DoS by crashing the server\n  3. SSRF\n2. Prompt Injection, both System and User\n  1. Full control over LLM prompts\n  2. Server variable and data exfiltration\nAnd many many more such as altering the flow of a conversation, prompt exfiltration via LLM proxying etc.\n\nThese issues are self-targeted and do not persist to other users but do leave the server and business exposed. \nAll issues are shown with the API but also work with the web embed.\n\n### Workarounds\n- `overrideConfig` should be disabled by default\n- `overrideConfig` should have an explicit allow list of variables that are allowed to be modified. This way the user opts-in to where modifications can be made. \n","public_affected_ranges":["< 2.1.4"]}],"null_published_at":"2026-11-02T10:00:37.146Z","source_updated_at":"2026-09-14T17:15:31.000Z","source_disclosed_at":"2024-11-21T22:21:03.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-01T22:54:05.264Z"}],"next_cursor":null,"snapshot_revision":"42594"}