{"items":[{"id":"NVI-00014134","kind":"vulnerability","title":"Duplicate Advisory: Nokogiri CSS selector tokenizer has regular expression backtracking","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"withdrawn","identifiers":["GHSA-5jhf-fpp7-v2pv"],"plain_summary":"GitHub lists this reviewed advisory for nokogiri. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-4e41d1397c93bf96d91fdb39b2f81e13"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-09-02T14:43:14.000Z","value":"7.5 high","meaning":"GitHub source severity; exploitability and local consequence require separate evidence.","source_id":"sr-4e41d1397c93bf96d91fdb39b2f81e13"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-4e41d1397c93bf96d91fdb39b2f81e13","url":"https://github.com/advisories/GHSA-5jhf-fpp7-v2pv","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-5jhf-fpp7-v2pv","publisher":"GitHub Advisory Database","observed_at":"2026-11-02T02:21:43.711Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-4e41d1397c93bf96d91fdb39b2f81e13"],"technology":"nokogiri","known_exclusions":[],"conditions_summary":"## Duplicate Advisory\n\nThis advisory has been withdrawn because it is a duplicate of GHSA-c4rq-3m3g-8wgx. This link is maintained to preserve external references.\n\n## Original Description\nNokogiri versions before 1.19.3 contain regular expression denial of service vulnerabilities in the CSS selector tokenizer affecting string-literal and identifier tokenization. Attackers can inject adversarial CSS selectors into methods like Node#css, Node#at_css, and Searchable#search to cause exponential regex backtracking and denial of service.","public_affected_ranges":["< 1.19.3"]}],"null_published_at":"2026-11-02T10:00:37.212Z","source_updated_at":"2026-09-02T14:43:14.000Z","source_disclosed_at":"2026-08-25T18:31:52.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-02T02:21:43.711Z"}],"next_cursor":null,"snapshot_revision":"42594"}