{"items":[{"id":"NVI-00014993","kind":"vulnerability","title":"ngx-extended-pdf-viewer bundles a version of pdf.js vulnerable to CVE-2026-16633","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-w9hm-4m3m-fxmm"],"plain_summary":"GitHub lists this reviewed advisory for ngx-extended-pdf-viewer. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-02fc81b0ea9041ffd7224b3a3e02409f"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-02fc81b0ea9041ffd7224b3a3e02409f","url":"https://github.com/advisories/GHSA-w9hm-4m3m-fxmm","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-w9hm-4m3m-fxmm","publisher":"GitHub Advisory Database","observed_at":"2026-11-03T02:28:46.523Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-02fc81b0ea9041ffd7224b3a3e02409f"],"technology":"ngx-extended-pdf-viewer","known_exclusions":[],"conditions_summary":"ngx-extended-pdf-viewer embeds a fork of Mozilla's pdf.js rather than depending on pdfjs-dist, so this vulnerability is not visible to dependency scanners through package.json.\n\n### Impact\nOpening a malicious PDF can execute attacker-controlled JavaScript in the context of the hosting page. Upstream advisory: GHSA-hq66-cqwq-w95j / CVE-2026-16633.\n\n### Exposure. \nThe sandbox half of the issue requires enableScripting, which pdf.js enables by default but this library does not — so the default configuration was less exposed than upstream's. The other half concerns XFA rich text and is reachable whenever enableXfa is true, which is the default here. Do not assume the default configuration was safe.\n\n### Patches\n29.0.0-rc.3 cherry-picks Mozilla's fix (pdf.js 6.2.108) into both the stable and bleeding-edge engines. Only the latest release receives security updates.\n\n### Workarounds\nSet pdfDefaultOptions.enableXfa = false if you do not need XFA forms, and/or apply a CSP disallowing inline script-src.\n\n### Verifying. \nFrom 29.0.0 the package ships sbom.json and vex.json. The SBOM records the applied fix as a CycloneDX pedigree.patches entry; the VEX carries a resolved_with_pedigree stateme","public_affected_ranges":[">= 27.0.0-rc.0, < 29.0.0-rc.3"]}],"null_published_at":"2026-11-03T10:03:26.532Z","source_updated_at":"2026-08-06T21:14:01.000Z","source_disclosed_at":"2026-08-06T21:13:59.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-03T02:28:46.523Z"}],"next_cursor":null,"snapshot_revision":"42594"}