{"items":[{"id":"NVI-00015006","kind":"vulnerability","title":"Weaviate has an Improper Authorization issue","revision":2,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected.","NVD lastModified does not establish freshness of every associated CPE record."],"lifecycle":"active","identifiers":["GHSA-jqpm-wf57-qx5c","CVE-2026-11500"],"plain_summary":"GitHub lists this reviewed advisory for github.com/weaviate/weaviate. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-0d985d121c18590473c316a047833407"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-07-29T15:41:15.000Z","value":"5 low","meaning":"GitHub source severity; exploitability and local consequence require separate evidence.","source_id":"sr-068df072fc5f18dd95ece4478eb5ed63"},{"kind":"CVSS","as_of":"2026-07-23T07:10:00.113Z","value":"4.6 MEDIUM (2.0)","meaning":"cna@vuldb.com severity; no combined Null risk score.","source_id":"sr-0d985d121c18590473c316a047833407"},{"kind":"CVSS","as_of":"2026-07-23T07:10:00.113Z","value":"5 MEDIUM (3.1)","meaning":"cna@vuldb.com severity; no combined Null risk score.","source_id":"sr-0d985d121c18590473c316a047833407"},{"kind":"CVSS","as_of":"2026-07-23T07:10:00.113Z","value":"1.3 LOW (4.0)","meaning":"cna@vuldb.com severity; no combined Null risk score.","source_id":"sr-0d985d121c18590473c316a047833407"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-068df072fc5f18dd95ece4478eb5ed63","url":"https://github.com/advisories/GHSA-jqpm-wf57-qx5c","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-jqpm-wf57-qx5c","publisher":"GitHub Advisory Database","observed_at":"2026-11-03T09:59:04.660Z"},{"id":"sr-0d985d121c18590473c316a047833407","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-11500","basis":"official_catalog","notes":"This product uses data from the NVD API but is not endorsed or certified by the NVD.","title":"CVE-2026-11500","publisher":"NIST National Vulnerability Database","observed_at":"2026-11-07T00:52:47.527Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-068df072fc5f18dd95ece4478eb5ed63"],"technology":"github.com/weaviate/weaviate","known_exclusions":[],"conditions_summary":"A vulnerability was identified in Weaviate up to 1.37.7. This vulnerability affects the function validateConfig of the file usecases/auth/authentication/apikey/client.go of the component Static API Key Handler. The manipulation of the argument StaticApiKey leads to authorization bypass. It is possible to initiate the attack remotely. The complexity of an attack is rather high. It is stated that the exploitability is difficult. The exploit is publicly available and might be used. Upgrading to version 1.38.0-rc.0 is able to resolve this issue. The identifier of the patch is 40f2cc32279f0f8a51016c3c6870a2c0c808e6c0. You should upgrade the affected component.","public_affected_ranges":["< 1.38.0-rc.0"]}],"null_published_at":"2026-11-07T18:43:12.063Z","source_updated_at":"2026-07-29T15:41:15.000Z","source_disclosed_at":"2026-06-08T12:30:28.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"Source facts changed; compare the preserved prior revision.","null_first_observed_at":"2026-11-03T09:59:04.660Z"},{"id":"NVI-00015006","kind":"vulnerability","title":"Weaviate has an Improper Authorization issue","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-jqpm-wf57-qx5c","CVE-2026-11500"],"plain_summary":"GitHub lists this reviewed advisory for github.com/weaviate/weaviate. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-068df072fc5f18dd95ece4478eb5ed63"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-07-29T15:41:15.000Z","value":"5 low","meaning":"GitHub source severity; exploitability and local consequence require separate evidence.","source_id":"sr-068df072fc5f18dd95ece4478eb5ed63"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-068df072fc5f18dd95ece4478eb5ed63","url":"https://github.com/advisories/GHSA-jqpm-wf57-qx5c","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-jqpm-wf57-qx5c","publisher":"GitHub Advisory Database","observed_at":"2026-11-03T09:59:04.660Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-068df072fc5f18dd95ece4478eb5ed63"],"technology":"github.com/weaviate/weaviate","known_exclusions":[],"conditions_summary":"A vulnerability was identified in Weaviate up to 1.37.7. This vulnerability affects the function validateConfig of the file usecases/auth/authentication/apikey/client.go of the component Static API Key Handler. The manipulation of the argument StaticApiKey leads to authorization bypass. It is possible to initiate the attack remotely. The complexity of an attack is rather high. It is stated that the exploitability is difficult. The exploit is publicly available and might be used. Upgrading to version 1.38.0-rc.0 is able to resolve this issue. The identifier of the patch is 40f2cc32279f0f8a51016c3c6870a2c0c808e6c0. You should upgrade the affected component.","public_affected_ranges":["< 1.38.0-rc.0"]}],"null_published_at":"2026-11-03T10:03:26.533Z","source_updated_at":"2026-07-29T15:41:15.000Z","source_disclosed_at":"2026-06-08T12:30:28.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-03T09:59:04.660Z"}],"next_cursor":null,"snapshot_revision":"42594"}