{"items":[{"id":"NVI-00016224","kind":"vulnerability","title":"vLLM deserialization vulnerability leading to DoS and potential RCE","revision":2,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected.","NVD lastModified does not establish freshness of every associated CPE record."],"lifecycle":"active","identifiers":["GHSA-mrw7-hf4f-83pf","CVE-2025-62164"],"plain_summary":"GitHub lists this reviewed advisory for vllm. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-46b22d1ee65f1d968a7b47f17844d6cc"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-07-17T16:15:45.000Z","value":"8.8 high","meaning":"GitHub source severity; exploitability and local consequence require separate evidence.","source_id":"sr-4ccf78a7d9867b28fb8825ac95b4f965"},{"kind":"CVSS","as_of":"2026-10-19T13:10:00.110Z","value":"8.8 HIGH (3.1)","meaning":"security-advisories@github.com severity; no combined Null risk score.","source_id":"sr-46b22d1ee65f1d968a7b47f17844d6cc"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-4ccf78a7d9867b28fb8825ac95b4f965","url":"https://github.com/advisories/GHSA-mrw7-hf4f-83pf","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-mrw7-hf4f-83pf","publisher":"GitHub Advisory Database","observed_at":"2026-11-04T09:59:26.779Z"},{"id":"sr-46b22d1ee65f1d968a7b47f17844d6cc","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-62164","basis":"official_catalog","notes":"This product uses data from the NVD API but is not endorsed or certified by the NVD.","title":"CVE-2025-62164","publisher":"NIST National Vulnerability Database","observed_at":"2026-11-06T15:14:16.847Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-4ccf78a7d9867b28fb8825ac95b4f965"],"technology":"vllm","known_exclusions":[],"conditions_summary":"### Summary\nA memory corruption vulnerability that leading to a crash (denial-of-service) and potentially remote code execution (RCE) exists in vLLM versions 0.10.2 and later, in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation.\n\nDue to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM.\n\n### Details\nA vulnerability that can lead to RCE from the completions API endpoint exists in vllm, where due to missing checks when loading user-provided tensors, an out-of-bounds write can be triggered. This happens because the default behavior of `torch.load(tensor, weights_only=True)`  since pytorch 2.8.0 is to not perform validity checks for sparse tensors, and this needs to be enabled explicitly using the [torch.sparse.check_sparse_tensor_invariants](https://docs.pytorch.org/docs/stable/g","public_affected_ranges":[">= 0.10.2, < 0.11.1"]}],"null_published_at":"2026-11-07T18:43:12.107Z","source_updated_at":"2026-07-17T16:15:45.000Z","source_disclosed_at":"2025-11-20T20:59:34.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"Source facts changed; compare the preserved prior revision.","null_first_observed_at":"2026-11-04T09:59:26.779Z"},{"id":"NVI-00016224","kind":"vulnerability","title":"vLLM deserialization vulnerability leading to DoS and potential RCE","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-mrw7-hf4f-83pf","CVE-2025-62164"],"plain_summary":"GitHub lists this reviewed advisory for vllm. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-4ccf78a7d9867b28fb8825ac95b4f965"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-07-17T16:15:45.000Z","value":"8.8 high","meaning":"GitHub source severity; exploitability and local consequence require separate evidence.","source_id":"sr-4ccf78a7d9867b28fb8825ac95b4f965"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-4ccf78a7d9867b28fb8825ac95b4f965","url":"https://github.com/advisories/GHSA-mrw7-hf4f-83pf","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-mrw7-hf4f-83pf","publisher":"GitHub Advisory Database","observed_at":"2026-11-04T09:59:26.779Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-4ccf78a7d9867b28fb8825ac95b4f965"],"technology":"vllm","known_exclusions":[],"conditions_summary":"### Summary\nA memory corruption vulnerability that leading to a crash (denial-of-service) and potentially remote code execution (RCE) exists in vLLM versions 0.10.2 and later, in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation.\n\nDue to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM.\n\n### Details\nA vulnerability that can lead to RCE from the completions API endpoint exists in vllm, where due to missing checks when loading user-provided tensors, an out-of-bounds write can be triggered. This happens because the default behavior of `torch.load(tensor, weights_only=True)`  since pytorch 2.8.0 is to not perform validity checks for sparse tensors, and this needs to be enabled explicitly using the [torch.sparse.check_sparse_tensor_invariants](https://docs.pytorch.org/docs/stable/g","public_affected_ranges":[">= 0.10.2, < 0.11.1"]}],"null_published_at":"2026-11-04T10:04:27.920Z","source_updated_at":"2026-07-17T16:15:45.000Z","source_disclosed_at":"2025-11-20T20:59:34.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-04T09:59:26.779Z"}],"next_cursor":null,"snapshot_revision":"42594"}