{"items":[{"id":"NVI-00016226","kind":"vulnerability","title":"n8n: Legacy Expression Evaluator Sanitizer Bypass Leads to Authenticated Code Execution","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-pm35-fqvh-cq5g","CVE-2026-65591"],"plain_summary":"GitHub lists this reviewed advisory for n8n, n8n, n8n. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-4d6dc11b932f0ab7ef5e2a634288aed6"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-4d6dc11b932f0ab7ef5e2a634288aed6","url":"https://github.com/advisories/GHSA-pm35-fqvh-cq5g","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-pm35-fqvh-cq5g","publisher":"GitHub Advisory Database","observed_at":"2026-11-03T17:42:43.803Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-4d6dc11b932f0ab7ef5e2a634288aed6"],"technology":"n8n","known_exclusions":[],"conditions_summary":"## Impact\nThe legacy expression evaluator's computed-member sanitizer can be bypassed by an authenticated user with workflow create or modify permissions. Successful exploitation grants the attacker host-level code execution as the n8n process.\n\nThe legacy expression engine is the default engine in affected versions.\n\n## Patches\nThe issue has been fixed in n8n versions 1.123.64, 2.29.8, and 2.30.1. Users should upgrade to one of these versions or later to remediate the vulnerability.\n\n## Workarounds\nIf upgrading is not immediately possible, administrators should consider the following temporary mitigations:\n- Restrict n8n instance access to fully trusted users only.\n- Switch to the non-legacy expression engine by setting `N8N_EXPRESSION_ENGINE=vm`.\n\nThese workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.","public_affected_ranges":["< 1.123.64"]},{"certainty":"source_listed","source_ids":["sr-4d6dc11b932f0ab7ef5e2a634288aed6"],"technology":"n8n","known_exclusions":[],"conditions_summary":"## Impact\nThe legacy expression evaluator's computed-member sanitizer can be bypassed by an authenticated user with workflow create or modify permissions. Successful exploitation grants the attacker host-level code execution as the n8n process.\n\nThe legacy expression engine is the default engine in affected versions.\n\n## Patches\nThe issue has been fixed in n8n versions 1.123.64, 2.29.8, and 2.30.1. Users should upgrade to one of these versions or later to remediate the vulnerability.\n\n## Workarounds\nIf upgrading is not immediately possible, administrators should consider the following temporary mitigations:\n- Restrict n8n instance access to fully trusted users only.\n- Switch to the non-legacy expression engine by setting `N8N_EXPRESSION_ENGINE=vm`.\n\nThese workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.","public_affected_ranges":[">= 2.30.0, < 2.30.1"]},{"certainty":"source_listed","source_ids":["sr-4d6dc11b932f0ab7ef5e2a634288aed6"],"technology":"n8n","known_exclusions":[],"conditions_summary":"## Impact\nThe legacy expression evaluator's computed-member sanitizer can be bypassed by an authenticated user with workflow create or modify permissions. Successful exploitation grants the attacker host-level code execution as the n8n process.\n\nThe legacy expression engine is the default engine in affected versions.\n\n## Patches\nThe issue has been fixed in n8n versions 1.123.64, 2.29.8, and 2.30.1. Users should upgrade to one of these versions or later to remediate the vulnerability.\n\n## Workarounds\nIf upgrading is not immediately possible, administrators should consider the following temporary mitigations:\n- Restrict n8n instance access to fully trusted users only.\n- Switch to the non-legacy expression engine by setting `N8N_EXPRESSION_ENGINE=vm`.\n\nThese workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.","public_affected_ranges":[">= 2.0.0-rc.0, < 2.29.8"]}],"null_published_at":"2026-11-04T10:04:27.920Z","source_updated_at":"2026-07-22T22:02:05.000Z","source_disclosed_at":"2026-07-22T22:02:04.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-03T17:42:43.803Z"}],"next_cursor":null,"snapshot_revision":"42594"}