{"items":[{"id":"NVI-00016239","kind":"vulnerability","title":"n8n: Member-Level Users Can Execute Other Users' MCP Server Trigger Workflows via Missing OAuth Authorization Check","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-q5xf-xhwf-cwqf","CVE-2026-65594"],"plain_summary":"GitHub lists this reviewed advisory for n8n, n8n. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-520f437b3fb259812222fc5f646623a7"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-520f437b3fb259812222fc5f646623a7","url":"https://github.com/advisories/GHSA-q5xf-xhwf-cwqf","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-q5xf-xhwf-cwqf","publisher":"GitHub Advisory Database","observed_at":"2026-11-03T17:42:43.803Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-520f437b3fb259812222fc5f646623a7"],"technology":"n8n","known_exclusions":[],"conditions_summary":"## Impact\nThe OAuth 2.1 consent and token-issuance flow introduced in n8n 2.27.0 does not verify that the authenticated user has access to the workflow referenced as the OAuth resource. A member-level user can register an OAuth client, self-approve consent for another user's `n8n OAuth2`-protected MCP Server Trigger workflow, and obtain a valid token for it.\n\nThe workflow runs in the owner's project context with the owner's stored credentials. The attacker sets the tool inputs and reads the outputs, which may include data from the owner's connected integrations, breaking user and project isolation. The resulting executions appear under the owner's account and are not visible to the attacker.\n\nThis issue only affects instances running n8n 2.27.0 or later where at least one active workflow uses an MCP Server Trigger node configured with `n8n OAuth2` authentication.\n\n## Patches\nThe issue has been fixed in n8n versions 2.29.8 and 2.30.1. Users should upgrade to one of these versions or later to remediate the vulnerability.\n\n## Workarounds\nIf upgrading is not immediately possible, administrators should consider the following temporary mitigations:\n- Restrict n8n instance access to fully","public_affected_ranges":[">= 2.30.0, < 2.30.1"]},{"certainty":"source_listed","source_ids":["sr-520f437b3fb259812222fc5f646623a7"],"technology":"n8n","known_exclusions":[],"conditions_summary":"## Impact\nThe OAuth 2.1 consent and token-issuance flow introduced in n8n 2.27.0 does not verify that the authenticated user has access to the workflow referenced as the OAuth resource. A member-level user can register an OAuth client, self-approve consent for another user's `n8n OAuth2`-protected MCP Server Trigger workflow, and obtain a valid token for it.\n\nThe workflow runs in the owner's project context with the owner's stored credentials. The attacker sets the tool inputs and reads the outputs, which may include data from the owner's connected integrations, breaking user and project isolation. The resulting executions appear under the owner's account and are not visible to the attacker.\n\nThis issue only affects instances running n8n 2.27.0 or later where at least one active workflow uses an MCP Server Trigger node configured with `n8n OAuth2` authentication.\n\n## Patches\nThe issue has been fixed in n8n versions 2.29.8 and 2.30.1. Users should upgrade to one of these versions or later to remediate the vulnerability.\n\n## Workarounds\nIf upgrading is not immediately possible, administrators should consider the following temporary mitigations:\n- Restrict n8n instance access to fully","public_affected_ranges":["< 2.29.8"]}],"null_published_at":"2026-11-04T10:04:27.921Z","source_updated_at":"2026-07-22T22:31:02.000Z","source_disclosed_at":"2026-07-22T22:31:01.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-03T17:42:43.803Z"}],"next_cursor":null,"snapshot_revision":"42594"}