{"items":[{"id":"NVI-00017507","kind":"vulnerability","title":"Fluentd is Vulnerable to Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-44hj-4m45-frj3","CVE-2026-44024"],"plain_summary":"GitHub lists this reviewed advisory for fluentd. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-0de52dde5a415adc7d61233b4f5e5d84"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-06-26T16:32:06.000Z","value":"9.8 critical","meaning":"GitHub source severity; exploitability and local consequence require separate evidence.","source_id":"sr-0de52dde5a415adc7d61233b4f5e5d84"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-0de52dde5a415adc7d61233b4f5e5d84","url":"https://github.com/advisories/GHSA-44hj-4m45-frj3","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-44hj-4m45-frj3","publisher":"GitHub Advisory Database","observed_at":"2026-11-05T19:05:53.922Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-0de52dde5a415adc7d61233b4f5e5d84"],"technology":"fluentd","known_exclusions":[],"conditions_summary":"Fluentd allows dynamically constructing file paths using the `${tag}` placeholder.\nIt was discovered that validation for this placeholder was insufficient.\n\nIf a Fluentd instance is configured to receive logs from untrusted sources and uses the `${tag}` placeholder in file configurations (such as the `path` parameter in the `out_file` plugin), an attacker can inject path traversal characters (e.g., `../`).\n\nWhen combined with certain formatting options, this vulnerability allows an attacker to write arbitrary files or overwrite existing files on the system with attacker-controlled content, bypassing intended directory restrictions.\n\n### Impact\nThis vulnerability allows for **Arbitrary File Write**, which can be directly escalated to full **Remote Code Execution (RCE)**.\nAn attacker could achieve RCE by overwriting critical system files, injecting executable plugins, or modifying configuration files.\nThe impact is Critical as it can lead to full system compromise without any authentication, depending on the Fluentd configuration and the privileges of the Fluentd process.\n\n### Patches\nv1.19.3\n\n### Workarounds\nIf an immediate upgrade is not possible, users are strongly advised to appl","public_affected_ranges":["<= 1.19.2"]}],"null_published_at":"2026-11-05T19:10:21.400Z","source_updated_at":"2026-06-26T16:32:06.000Z","source_disclosed_at":"2026-06-26T16:32:05.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-05T19:05:53.922Z"}],"next_cursor":null,"snapshot_revision":"42594"}