{"items":[{"id":"NVI-00017570","kind":"vulnerability","title":"Apache Syncope Vulnerable to Exposure of Sensitive Information Through Data Queries","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-vr35-jm2f-8wg2","CVE-2026-42797"],"plain_summary":"GitHub lists this reviewed advisory for org.apache.syncope.core:syncope-core-provisioning-api, org.apache.syncope.core:syncope-core-provisioning-api, org.apache.syncope.core:syncope-core-provisioning-api. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-23825b9f01307649fc00e3c0138051d9"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-06-30T17:19:30.000Z","value":"4.9 medium","meaning":"GitHub source severity; exploitability and local consequence require separate evidence.","source_id":"sr-23825b9f01307649fc00e3c0138051d9"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-23825b9f01307649fc00e3c0138051d9","url":"https://github.com/advisories/GHSA-vr35-jm2f-8wg2","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-vr35-jm2f-8wg2","publisher":"GitHub Advisory Database","observed_at":"2026-11-05T11:39:31.286Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-23825b9f01307649fc00e3c0138051d9"],"technology":"org.apache.syncope.core:syncope-core-provisioning-api","known_exclusions":[],"conditions_summary":"Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope.\n\nAn administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information.\n\nThis issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0.\n\nUsers are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.","public_affected_ranges":[">= 3.0.0-M0, <= 3.0.16"]},{"certainty":"source_listed","source_ids":["sr-23825b9f01307649fc00e3c0138051d9"],"technology":"org.apache.syncope.core:syncope-core-provisioning-api","known_exclusions":[],"conditions_summary":"Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope.\n\nAn administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information.\n\nThis issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0.\n\nUsers are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.","public_affected_ranges":[">= 4.0.0-M0, < 4.0.6"]},{"certainty":"source_listed","source_ids":["sr-23825b9f01307649fc00e3c0138051d9"],"technology":"org.apache.syncope.core:syncope-core-provisioning-api","known_exclusions":[],"conditions_summary":"Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope.\n\nAn administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information.\n\nThis issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0.\n\nUsers are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.","public_affected_ranges":[">= 4.1.0-M0, < 4.1.1"]}],"null_published_at":"2026-11-05T19:10:21.418Z","source_updated_at":"2026-06-30T17:19:30.000Z","source_disclosed_at":"2026-05-26T13:30:46.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-05T11:39:31.286Z"}],"next_cursor":null,"snapshot_revision":"42594"}