{"items":[{"id":"NVI-00017702","kind":"vulnerability","title":"PyYAML insecurely deserializes YAML strings leading to arbitrary code execution","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-rprw-h62v-c2w7","CVE-2017-18342"],"plain_summary":"GitHub lists this reviewed advisory for PyYAML. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-4ae88b7be989799f8ee272fc3a8d796e"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-07-01T17:39:14.000Z","value":"9.8 critical","meaning":"GitHub source severity; exploitability and local consequence require separate evidence.","source_id":"sr-4ae88b7be989799f8ee272fc3a8d796e"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-4ae88b7be989799f8ee272fc3a8d796e","url":"https://github.com/advisories/GHSA-rprw-h62v-c2w7","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-rprw-h62v-c2w7","publisher":"GitHub Advisory Database","observed_at":"2026-11-05T11:39:31.286Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-4ae88b7be989799f8ee272fc3a8d796e"],"technology":"PyYAML","known_exclusions":[],"conditions_summary":"In PyYAML before 5.1, the `yaml.load()` API could execute arbitrary code. In other words, `yaml.safe_load` is not used.\n\nThis was intended to be fixed in 4.1, but due to breaking changes, 4.1 was yanked and 5.1 contains the patch for CVE-2017-18342.","public_affected_ranges":["< 5.1"]}],"null_published_at":"2026-11-05T19:10:21.454Z","source_updated_at":"2026-07-01T17:39:14.000Z","source_disclosed_at":"2019-01-04T17:45:26.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-05T11:39:31.286Z"}],"next_cursor":null,"snapshot_revision":"42594"}