{"items":[{"id":"NVI-00017723","kind":"vulnerability","title":"yeoman-environment Vulnerable to Arbitrary Package Installation without User Confirmation","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-vv9j-gjw2-j8wp","CVE-2026-42089"],"plain_summary":"GitHub lists this reviewed advisory for yeoman-environment. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-4f2ad0df6378155b3a279f60c6f4557b"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-07-08T17:36:50.000Z","value":"8.6 high","meaning":"GitHub source severity; exploitability and local consequence require separate evidence.","source_id":"sr-4f2ad0df6378155b3a279f60c6f4557b"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-4f2ad0df6378155b3a279f60c6f4557b","url":"https://github.com/advisories/GHSA-vv9j-gjw2-j8wp","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-vv9j-gjw2-j8wp","publisher":"GitHub Advisory Database","observed_at":"2026-11-04T23:34:51.634Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-4f2ad0df6378155b3a279f60c6f4557b"],"technology":"yeoman-environment","known_exclusions":[],"conditions_summary":"### Impact\n\n`yeoman-environment` versions `>= 2.9.0` and `< 6.0.1` install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap.\n\nThe vulnerable method is `installLocalGenerators()`, which calls `repository.install()` directly without prompting the user.\n\n### Patches\n\nUpgrade to `yeoman-environment` `6.0.1`, which adds an interactive confirmation prompt before installation (PR #753).\n\n### Workarounds\n\nNone.\n\n### Resources\n\n- Fix commit 78d2af7","public_affected_ranges":[">= 2.9.0, < 6.0.1"]}],"null_published_at":"2026-11-05T19:10:21.457Z","source_updated_at":"2026-07-08T17:36:50.000Z","source_disclosed_at":"2026-05-26T23:10:38.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-04T23:34:51.634Z"}],"next_cursor":null,"snapshot_revision":"42594"}