{"items":[{"id":"NVI-00017818","kind":"vulnerability","title":"OpenAM OAuth Authorization Bypass via PKCE Challenge","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-4v2w-2wqp-mc85","CVE-2026-48717"],"plain_summary":"GitHub lists this reviewed advisory for org.openidentityplatform.openam:openam-oauth2. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-6dbad9993fb7a8de5dec112ee94f8bdd"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-6dbad9993fb7a8de5dec112ee94f8bdd","url":"https://github.com/advisories/GHSA-4v2w-2wqp-mc85","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-4v2w-2wqp-mc85","publisher":"GitHub Advisory Database","observed_at":"2026-11-05T19:05:04.022Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-6dbad9993fb7a8de5dec112ee94f8bdd"],"technology":"org.openidentityplatform.openam:openam-oauth2","known_exclusions":[],"conditions_summary":"## Summary\n\n**Description**\n\nAn Improper Authorization (CWE-285) issue in OpenAM's OAuth2 authorization-code grant allows a PKCE-protected authorization code to be redeemed without the required code_verifier. This affects OpenAM Community Edition through version 16.0.6 and was patched in version 16.1.1.\n\nThe authorize endpoint stores a code_challenge on the issued code, but the token endpoint only requires a code_verifier when the realm-wide codeVerifierEnforced setting is enabled, which ships disabled by default. With that setting off, the stored challenge is checked only if the caller supplies a verifier, so omitting the parameter skips PKCE verification entirely.\n\n## Impact\nOpenAM Community Edition deployments through version 16.0.6 using the default OAuth2 provider configuration are potentially affected. For public clients, an attacker who intercepts an authorization code can exchange it for tokens without knowing the verifier. For confidential clients, the attacker additionally needs client authentication material or an execution context that can redeem the code. A token request supplying an incorrect verifier is still rejected. The bypass is specifically the missing-parameter","public_affected_ranges":["<= 16.0.6"]}],"null_published_at":"2026-11-05T19:10:21.471Z","source_updated_at":"2026-06-29T17:46:07.000Z","source_disclosed_at":"2026-06-29T17:46:06.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-05T19:05:04.022Z"}],"next_cursor":null,"snapshot_revision":"42594"}