{"items":[{"id":"NVI-00017857","kind":"vulnerability","title":"Apache NiFi allows read-only users to submit component configuration verification request","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-qvj8-gwpm-4x49","CVE-2026-44911"],"plain_summary":"GitHub lists this reviewed advisory for org.apache.nifi:nifi-web-api. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-742346c714526da00771e16a5452bf01"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-742346c714526da00771e16a5452bf01","url":"https://github.com/advisories/GHSA-qvj8-gwpm-4x49","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-qvj8-gwpm-4x49","publisher":"GitHub Advisory Database","observed_at":"2026-11-01T22:54:05.264Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-742346c714526da00771e16a5452bf01"],"technology":"org.apache.nifi:nifi-web-api","known_exclusions":[],"conditions_summary":"Authorization handling for component configuration verification requests in Apache NiFi 1.15.0 through 2.9.0 allows clients with read access to submit proposed configuration properties. The proposed properties override current configuration, enabling users with read access to invoke predefined verification methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying component configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, requiring write access to submit configuration verification requests.","public_affected_ranges":[">= 1.15.0, < 2.10.0"]}],"null_published_at":"2026-11-05T19:10:21.476Z","source_updated_at":"2026-09-11T22:07:30.000Z","source_disclosed_at":"2026-06-22T09:30:45.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-01T22:54:05.264Z"}],"next_cursor":null,"snapshot_revision":"42594"}