{"items":[{"id":"NVI-00018317","kind":"vulnerability","title":"Apache Tomcat vulnerable to Generation of Error Message Containing Sensitive Information","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-f4qf-m5gf-8jm8","CVE-2024-21733"],"plain_summary":"GitHub lists this reviewed advisory for org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat-coyote, org.apache.tomcat.experimental:tomcat-embed-programmatic. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-0fa413d3aed2b4adde689c5bf2b8f8d3"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-06-18T23:16:08.000Z","value":"5.3 medium","meaning":"GitHub source severity; exploitability and local consequence require separate evidence.","source_id":"sr-0fa413d3aed2b4adde689c5bf2b8f8d3"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-0fa413d3aed2b4adde689c5bf2b8f8d3","url":"https://github.com/advisories/GHSA-f4qf-m5gf-8jm8","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-f4qf-m5gf-8jm8","publisher":"GitHub Advisory Database","observed_at":"2026-11-06T07:19:16.585Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-0fa413d3aed2b4adde689c5bf2b8f8d3"],"technology":"org.apache.tomcat:tomcat-coyote","known_exclusions":[],"conditions_summary":"Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43.\n\nUsers are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.","public_affected_ranges":[">= 9.0.0-M11, < 9.0.44"]},{"certainty":"source_listed","source_ids":["sr-0fa413d3aed2b4adde689c5bf2b8f8d3"],"technology":"org.apache.tomcat.embed:tomcat-embed-core","known_exclusions":[],"conditions_summary":"Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43.\n\nUsers are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.","public_affected_ranges":[">= 8.5.7, < 8.5.64"]},{"certainty":"source_listed","source_ids":["sr-0fa413d3aed2b4adde689c5bf2b8f8d3"],"technology":"org.apache.tomcat.embed:tomcat-embed-core","known_exclusions":[],"conditions_summary":"Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43.\n\nUsers are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.","public_affected_ranges":[">= 9.0.0-M11, < 9.0.44"]},{"certainty":"source_listed","source_ids":["sr-0fa413d3aed2b4adde689c5bf2b8f8d3"],"technology":"org.apache.tomcat:tomcat-coyote","known_exclusions":[],"conditions_summary":"Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43.\n\nUsers are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.","public_affected_ranges":[">= 8.5.7, < 8.5.64"]},{"certainty":"source_listed","source_ids":["sr-0fa413d3aed2b4adde689c5bf2b8f8d3"],"technology":"org.apache.tomcat.experimental:tomcat-embed-programmatic","known_exclusions":[],"conditions_summary":"Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43.\n\nUsers are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.","public_affected_ranges":[">= 9.0.43, < 9.0.44"]}],"null_published_at":"2026-11-07T07:07:39.810Z","source_updated_at":"2026-06-18T23:16:08.000Z","source_disclosed_at":"2024-01-19T12:30:18.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-06T07:19:16.585Z"}],"next_cursor":null,"snapshot_revision":"39771"}