{"items":[{"id":"NVI-00018469","kind":"vulnerability","title":"MCP Toolbox for Databases: authenticated authorization bypass","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-5gf6-gc35-xjpc","CVE-2026-11719"],"plain_summary":"GitHub lists this reviewed advisory for github.com/googleapis/mcp-toolbox. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-2a31a28f994b03af6c464a07b4e63c17"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-2a31a28f994b03af6c464a07b4e63c17","url":"https://github.com/advisories/GHSA-5gf6-gc35-xjpc","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-5gf6-gc35-xjpc","publisher":"GitHub Advisory Database","observed_at":"2026-11-06T07:19:16.585Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-2a31a28f994b03af6c464a07b4e63c17"],"technology":"github.com/googleapis/mcp-toolbox","known_exclusions":[],"conditions_summary":"An authenticated authorization bypass vulnerability exists in MCP Toolbox for Databases due to missing scope enforcement across older protocol handlers.\n\nWhile the 2025-11-25 protocol version handler correctly enforces per-tool restrictions defined by scopesRequired, older supported protocol versions (2025-06-18, 2025-03-26, and 2024-11-05) omit this check. An authenticated client with low-privilege tokens (e.g., read) can bypass the intended per-tool scope restrictions and execute high-privilege tools (e.g., admin) simply by specifying an older protocol version in the MCP-Protocol-Version header, or by omitting the header entirely (which causes the server to default to the vulnerable 2024-11-05 handler).","public_affected_ranges":["< 1.4.0"]}],"null_published_at":"2026-11-07T07:07:39.839Z","source_updated_at":"2026-06-19T17:00:03.000Z","source_disclosed_at":"2026-06-18T15:32:02.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-06T07:19:16.585Z"}],"next_cursor":null,"snapshot_revision":"42594"}