{"items":[{"id":"NVI-00018555","kind":"vulnerability","title":"@babel/plugin-transform-modules-systemjs generates arbitrary code when compiling malicious input","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-fv7c-fp4j-7gwp","CVE-2026-44728"],"plain_summary":"GitHub lists this reviewed advisory for @babel/plugin-transform-modules-systemjs, @babel/plugin-transform-modules-systemjs. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-3b56c0cb02a4891a702d5068b26a7ec6"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-06-08T23:28:10.000Z","value":"8.2 high","meaning":"GitHub source severity; exploitability and local consequence require separate evidence.","source_id":"sr-3b56c0cb02a4891a702d5068b26a7ec6"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-3b56c0cb02a4891a702d5068b26a7ec6","url":"https://github.com/advisories/GHSA-fv7c-fp4j-7gwp","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-fv7c-fp4j-7gwp","publisher":"GitHub Advisory Database","observed_at":"2026-11-07T00:51:53.608Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-3b56c0cb02a4891a702d5068b26a7ec6"],"technology":"@babel/plugin-transform-modules-systemjs","known_exclusions":[],"conditions_summary":"### Impact\n\nUsing Babel to compile code that was specifically crafted by an attacker can cause Babel to generate output code that executes arbitrary code.\n\nKnown affected plugins are:\n- `@babel/plugin-transform-modules-systemjs`\n- `@babel/preset-env` when using the `modules: \"systemjs\"` option, as it delegates to `@babel/plugin-transform-modules-systemjs`\n\nNo other plugins under the `@babel` namespace are impacted.\n\n**Users that only compile trusted code are not impacted.**\n\n### Patches\n\nThe vulnerability has been fixed in `@babel/plugin-transform-modules-systemjs@7.29.4`.\n\nBabel also released `@babel/preset-env@7.29.5`, updating its `@babel/plugin-transform-modules-systemjs` dependency, to simplify forcing the update if you are using `@babel/preset-env` directly.\n\n### Workarounds\n\n- Pin `@babel/parser` to v7.11.5. The downgrade will completely disable string module name parsing, but it would also disable other new language features and the build pipeline may fail as a result. Only do so if you are working on a legacy codebase and can not upgrade `@babel/plugin-transform-modules-systemjs` to v7.29.4.\n- Do not use the `modules: \"sys","public_affected_ranges":[">= 7.12.0, <= 7.29.3"]},{"certainty":"source_listed","source_ids":["sr-3b56c0cb02a4891a702d5068b26a7ec6"],"technology":"@babel/plugin-transform-modules-systemjs","known_exclusions":[],"conditions_summary":"### Impact\n\nUsing Babel to compile code that was specifically crafted by an attacker can cause Babel to generate output code that executes arbitrary code.\n\nKnown affected plugins are:\n- `@babel/plugin-transform-modules-systemjs`\n- `@babel/preset-env` when using the `modules: \"systemjs\"` option, as it delegates to `@babel/plugin-transform-modules-systemjs`\n\nNo other plugins under the `@babel` namespace are impacted.\n\n**Users that only compile trusted code are not impacted.**\n\n### Patches\n\nThe vulnerability has been fixed in `@babel/plugin-transform-modules-systemjs@7.29.4`.\n\nBabel also released `@babel/preset-env@7.29.5`, updating its `@babel/plugin-transform-modules-systemjs` dependency, to simplify forcing the update if you are using `@babel/preset-env` directly.\n\n### Workarounds\n\n- Pin `@babel/parser` to v7.11.5. The downgrade will completely disable string module name parsing, but it would also disable other new language features and the build pipeline may fail as a result. Only do so if you are working on a legacy codebase and can not upgrade `@babel/plugin-transform-modules-systemjs` to v7.29.4.\n- Do not use the `modules: \"sys","public_affected_ranges":[">= 8.0.0-alpha.0, <= 8.0.0-alpha.12"]}],"null_published_at":"2026-11-07T07:07:39.853Z","source_updated_at":"2026-06-08T23:28:10.000Z","source_disclosed_at":"2026-05-08T20:34:07.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-07T00:51:53.608Z"}],"next_cursor":null,"snapshot_revision":"42594"}