{"items":[{"id":"NVI-00018618","kind":"vulnerability","title":"Supply chain compromise via malicious @cap-js/openapi","revision":1,"unknowns":["Customer inventory, deployment, reachability and exploitation have not been inspected."],"lifecycle":"active","identifiers":["GHSA-jpvj-wpmj-h7rv"],"plain_summary":"GitHub lists this reviewed advisory for @cap-js/openapi. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.","review_status":"source_listed","control_topics":[],"public_actions":[{"summary":"Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.","source_ids":["sr-450844516623f7424fb24962ddeae54c"],"action_type":"investigate","limitations":"Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system.","current_supported_target":null}],"schema_version":"1.1.0","source_metrics":[{"kind":"CVSS","as_of":"2026-06-04T19:37:04.000Z","value":"9.6 critical","meaning":"GitHub source severity; exploitability and local consequence require separate evidence.","source_id":"sr-450844516623f7424fb24962ddeae54c"}],"why_it_matters":"Published affected context helps an owner decide what evidence to gather. This report has not examined your application.","related_sources":[{"id":"sr-450844516623f7424fb24962ddeae54c","url":"https://github.com/advisories/GHSA-jpvj-wpmj-h7rv","basis":"vendor_advisory","notes":"GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.","title":"GHSA-jpvj-wpmj-h7rv","publisher":"GitHub Advisory Database","observed_at":"2026-11-07T00:53:06.181Z"}],"affected_context":[{"certainty":"source_listed","source_ids":["sr-450844516623f7424fb24962ddeae54c"],"technology":"@cap-js/openapi","known_exclusions":[],"conditions_summary":"### Impact\n\nOn May 19, 2026, a compromised version of @cap-js/openapi@1.4.1 was published.\nThe malicious packages harvested credentials and attempted self-propagation.\nIf a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised.\n\n### Patches\n\nUpgrade to @cap-js/openapi >= 1.4.2\nIf the compromised version was ever installed, rotate all affected credentials.\n\n### Workarounds\nNo workarounds.\n\n### References\n\n- SAP Note 3747787\n- Developer FAQ","public_affected_ranges":["= 1.4.1"]}],"null_published_at":"2026-11-07T07:07:39.863Z","source_updated_at":"2026-06-04T19:37:04.000Z","source_disclosed_at":"2026-06-04T19:37:04.000Z","is_synthetic_fixture":false,"null_last_reviewed_at":null,"public_change_summary":"First indexed by Null; source disclosure date is shown separately.","null_first_observed_at":"2026-11-07T00:53:06.181Z"}],"next_cursor":null,"snapshot_revision":"42594"}