By Null Ventures MCP platform
Menu

vulnerability / NVI-00005785 / Revision 2

YUI Cross-site Scripting (XSS) vulnerability

OSV carries this publisher advisory for yui, yui, moodle/moodle, moodle/moodle, moodle/moodle. This is an aggregated source copy; consult the original publisher and compare update dates.

source listedactiveGHSA-x5hj-47vv-53p8CVE-2013-4940

This report has not inspected your inventory, configuration, deployed build, reachability or evidence. A catalog listing and a severity score do not establish exposure or compromise.

01 / Meaning

Why it matters

Published affected context helps an owner decide what evidence to gather. This report has not examined your application.

02 / Applicability

The affected context

Affected versions, configuration prerequisites and known exclusions are public. Confirm each one against the deployed service.

yui

source listed
  • SEMVER: introduced 3.0.0; fixed 3.10.11

Cross-site scripting (XSS) vulnerability in io.swf in the IO Utility component in Yahoo! YUI 3.10.2, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL. NOTE: this vulnerability exists because of a CVE-2013-4939 regression.

GitHub Advisory Database via OSV

yui

source listed
  • SEMVER: introduced 3.10.12; fixed 3.10.13

Cross-site scripting (XSS) vulnerability in io.swf in the IO Utility component in Yahoo! YUI 3.10.2, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL. NOTE: this vulnerability exists because of a CVE-2013-4939 regression.

GitHub Advisory Database via OSV

moodle/moodle

source listed
  • ECOSYSTEM: introduced 0; fixed 2.2.11

Cross-site scripting (XSS) vulnerability in io.swf in the IO Utility component in Yahoo! YUI 3.10.2, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL. NOTE: this vulnerability exists because of a CVE-2013-4939 regression.

GitHub Advisory Database via OSV

moodle/moodle

source listed
  • ECOSYSTEM: introduced 2.3.0; fixed 2.3.8

Cross-site scripting (XSS) vulnerability in io.swf in the IO Utility component in Yahoo! YUI 3.10.2, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL. NOTE: this vulnerability exists because of a CVE-2013-4939 regression.

GitHub Advisory Database via OSV

moodle/moodle

source listed
  • ECOSYSTEM: introduced 2.4.0-rc1; fixed 2.4.5

Cross-site scripting (XSS) vulnerability in io.swf in the IO Utility component in Yahoo! YUI 3.10.2, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL. NOTE: this vulnerability exists because of a CVE-2013-4939 regression.

GitHub Advisory Database via OSV

moodle/moodle

source listed
  • ECOSYSTEM: introduced 2.5.0-beta; fixed 2.5.1

Cross-site scripting (XSS) vulnerability in io.swf in the IO Utility component in Yahoo! YUI 3.10.2, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL. NOTE: this vulnerability exists because of a CVE-2013-4939 regression.

GitHub Advisory Database via OSV

03 / Response

What to do next

  1. vendor patch

    The original advisory lists fixed boundaries 3.10.11 for yui. Confirm the publisher’s latest guidance.

    Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system. GitHub Advisory Database via OSV

  2. vendor patch

    The original advisory lists fixed boundaries 3.10.13 for yui. Confirm the publisher’s latest guidance.

    Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system. GitHub Advisory Database via OSV

  3. vendor patch

    The original advisory lists fixed boundaries 2.2.11 for moodle/moodle. Confirm the publisher’s latest guidance.

    Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system. GitHub Advisory Database via OSV

  4. vendor patch

    The original advisory lists fixed boundaries 2.3.8 for moodle/moodle. Confirm the publisher’s latest guidance.

    Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system. GitHub Advisory Database via OSV

  5. vendor patch

    The original advisory lists fixed boundaries 2.4.5 for moodle/moodle. Confirm the publisher’s latest guidance.

    Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system. GitHub Advisory Database via OSV

  6. vendor patch

    The original advisory lists fixed boundaries 2.5.1 for moodle/moodle. Confirm the publisher’s latest guidance.

    Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system. GitHub Advisory Database via OSV

  7. investigate

    Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.

    Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system. NIST National Vulnerability Database

A fixed release is not deployment evidence.

Check current vendor support and compatibility. After making a change, verify the deployed build and relevant runtime conditions. Keep the evidence, owner and time. An updated lockfile alone does not prove what is running.

04 / Limits

What this report cannot establish

  • Customer inventory, deployment, reachability and exploitation have not been inspected.
  • NVD lastModified does not establish freshness of every associated CPE record.
Read the collection and interpretation limits ↗

05 / Provenance

Sources you can inspect

Each assertion retains its source. Mirrored records may repeat one underlying publisher; additional links are not independent corroboration.

  1. GHSA-x5hj-47vv-53p8 ↗

    GitHub Advisory Database via OSV · vendor advisory

    Observed . GitHub-origin advisory, CC-BY-4.0; OSV is an aggregate copy, not independent corroboration.

  2. CVE-2013-4940 ↗

    NIST National Vulnerability Database · official catalog

    Observed . This product uses data from the NVD API but is not endorsed or certified by the NVD.

Public revision history

Only published revisions appear here. Routine fetches do not create a material-change event.

  1. Revision 2 ·

    Source facts changed; compare the preserved prior revision.

Read the public revision data ↗

The next step is private

Bring the question into your environment.

The connected workflow is a development preview for inventory, contextual matching, owner decisions and evidence-based verification. No system-specific result is generated by this page.

See the synthetic workflow preview ↗