vulnerability / NVI-00011859 / Revision 4
Backstage: Improper input validation in Sentry scaffolder actions
GitHub lists this reviewed advisory for @backstage/plugin-scaffolder-backend-module-sentry. Published version ranges and source prerequisites are shown below; this is not an inspection of a visitor’s application.
This report has not inspected your inventory, configuration, deployed build, reachability or evidence. A catalog listing and a severity score do not establish exposure or compromise.
01 / Meaning
Why it matters
Published affected context helps an owner decide what evidence to gather. This report has not examined your application.
8.5 high
GitHub source severity; exploitability and local consequence require separate evidence.
As of · GitHub Advisory Database
0.212%
FIRST EPSS model v2026.06.15; exploitation probability over 30 days, percentile 0.11564. Missing scores are unknown.
As of · FIRST EPSS
02 / Applicability
The affected context
Affected versions, configuration prerequisites and known exclusions are public. Confirm each one against the deployed service.
@backstage/plugin-scaffolder-backend-module-sentry
source listed>= 0.3.0, < 0.3.8
### Impact An authenticated internal user who can execute the affected actions may cause the backend to contact unintended destinations and disclose Sentry integration credentials. Subsequent impact depends on network reachability and the privileges granted to the configured token. ### Patches Upgrade `@backstage/plugin-scaffolder-backend-module-sentry` to version `0.3.8` or later. The fixed package is available in Backstage v1.54.8 and Backstage v1.55.0. The update removes custom action-level `apiBaseUrl` values. Move any such value to `scaffolder.sentry.apiBaseUrl` before upgrading. ### Workarounds - Disable the affected actions until the patched package is deployed. - Restrict `scaffolder.action.execute` permission for the affected Sentry actions to trusted users and templates.
03 / Response
What to do next
- investigate
Identify the exact component and deployed version, examine the linked publisher’s conditions, and retain evidence of any mitigation.
Confirm current vendor support, compatibility and deployment evidence. This report has not tested a fix in your system. FIRST EPSS
A fixed release is not deployment evidence.
Check current vendor support and compatibility. After making a change, verify the deployed build and relevant runtime conditions. Keep the evidence, owner and time. An updated lockfile alone does not prove what is running.
04 / Limits
What this report cannot establish
- Customer inventory, deployment, reachability and exploitation have not been inspected.
05 / Provenance
Sources you can inspect
Each assertion retains its source. Mirrored records may repeat one underlying publisher; additional links are not independent corroboration.
- GHSA-g734-fhp4-7mfp ↗
GitHub Advisory Database · vendor advisory
Observed . GitHub Advisory Database; CC-BY-4.0. Each advisory links its original attribution. Null normalizes fields.
- CVE-2026-106459 ↗
FIRST EPSS · official catalog
Observed . FIRST EPSS; probability of exploitation in the next 30 days, not local compromise. Dataset date/model retained; FIRST services terms apply.
Public revision history
Only published revisions appear here. Routine fetches do not create a material-change event.
- Revision 4 ·
Dated EPSS estimate updated; this is not a new disclosure or proof of exploitation.
- Revision 3 ·
Dated EPSS estimate updated; this is not a new disclosure or proof of exploitation.
- Revision 2 ·
Dated EPSS estimate updated; this is not a new disclosure or proof of exploitation.
- Revision 1 ·
First indexed by Null; source disclosure date is shown separately.